aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index 74efae753c..0d8217ee20 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -34,7 +34,6 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu))
-
(define-public rsync
(package
(name "rsync")
@@ -47,10 +46,17 @@
(base32
"1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ ;; The bundled copies are preferred by default.
+ (list "--without-included-zlib"
+ "--without-included-popt")))
(native-inputs
`(("perl" ,perl)))
(inputs
- `(("acl" ,acl)))
+ `(("acl" ,acl)
+ ("popt" ,popt)
+ ("zlib" ,zlib)))
(synopsis "Remote (and local) file copying tool")
(description
"Rsync is a fast and versatile file copying tool. It can copy locally,