aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 48dc3cddb9..22ea21dd94 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -22,6 +22,7 @@
#:use-module ((guix licenses)
#:select (non-copyleft isc gpl2 lgpl2.1 lgpl2.1+))
#:use-module (guix packages)
+ #:use-module (guix git-download)
#:use-module (guix download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -122,13 +123,14 @@ Java Lucene text search engine API to C++.")
(name "lrdf")
(version "0.6.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/swh/LRDF/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swh/LRDF.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1vxii4mlcpyi16dizcmnqfl2j9gffgr986yd8ic67hvs8xy42yfm"))))
+ "00wzkfb8y0aqd519ypz067cq099dpc89w69zw8ln39vl6f9x2pd4"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -140,9 +142,9 @@ Java Lucene text search engine API to C++.")
(("instances_test remove_test") "instances_test")
(("\\$\\(TESTS\\) remove_test") "$(TESTS)"))
#t))
- (add-after 'remove-out-of-tree-references 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ ;; The default bootstrap phase executes autogen.sh, which fails.
+ (replace 'bootstrap
+ (lambda _ (invoke "autoreconf" "-vif") #t)))))
(inputs
`(("raptor" ,raptor2)
("cyrus-sasl" ,cyrus-sasl)