aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 3ee3a2c044..929144f30d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
@@ -49,6 +50,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gperf)
@@ -427,11 +429,16 @@ system, and the core design of Django is reused in Grantlee.")
(inputs
`(,@(fold alist-delete
(package-inputs qt)
- '("harfbuzz" "libjpeg"))
+ '("harfbuzz" "libjpeg" "openssl"))
("libjpeg" ,libjpeg-8)
- ("libsm" ,libsm)))
+ ("libsm" ,libsm)
+ ("openssl" ,openssl-1.0)))
(native-inputs
- `(,@(fold alist-delete
+ `(;; XXX: The JavaScriptCore engine does not build with the C++11 standard.
+ ;; We could build it with -std=gnu++98, but then we'll get in trouble with
+ ;; ICU later. Just keep using GCC 5 for now.
+ ("gcc" ,gcc-5)
+ ,@(fold alist-delete
(package-native-inputs qt)
'("vulkan-headers"))))