aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c4407fea29..2b8b5923aa 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
#:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
"-DPORT=Qt"
"-DUSE_LIBHYPHEN=OFF"
- "-DUSE_SYSTEM_MALLOC=ON")))
+ "-DUSE_SYSTEM_MALLOC=ON"
+ ;; XXX: relative dir installs to build dir?
+ (string-append "-DECM_MKSPECS_INSTALL_DIR="
+ %output "/lib/qt5/mkspecs/modules")
+ ;; Sacrifice a little speed in order to link
+ ;; libraries and test executables in a
+ ;; reasonable amount of memory.
+ "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
+ "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
(home-page "https://www.webkit.org")
(synopsis "Web browser engine and classes to render and interact with web
content")