aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5b11a6371c..370c9ef112 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6624,6 +6624,25 @@ of the structure, dynamics, and functions of complex networks.")
(define-public python2-networkx
(package-with-python2 python-networkx))
+;; Define new package, because the current version of python-colormath does
+;; not build against 2.0.
+(define-public python-networkx2
+ (package (inherit python-networkx)
+ (name "python-networkx2")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "networkx" version ".zip"))
+ (sha256
+ (base32
+ "1ajl2jp8qry9nyjzzkqpy0vmsr14d23z1qk7y0vr5iwjbpvzhpyd"))
+ (patches
+ (search-patches "python-networkx2-reproducible-build.patch"))))))
+
+(define-public python2-networkx2
+ (package-with-python2 python-networkx2))
+
(define-public snakemake
(package
(name "snakemake")