aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 08207247d0..6147a13d97 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10238,6 +10238,30 @@ useful as a validator for JSON data.")
(define-public python2-validictory
(package-with-python2 python-validictory))
+(define-public python-pyemd
+ (package
+ (name "python-pyemd")
+ (version "0.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyemd" version))
+ (sha256
+ (base32
+ "13y06y7r1697cv4r430g45fxs40i2yk9xn0dk9nqlrpddw3a0mr4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (home-page "http://github.com/wmayner/pyemd")
+ (synopsis
+ "A Python wrapper for Ofir Pele and Michael Werman's implementation of the Earth Mover's Distance.")
+ (description
+ "A Python wrapper for Ofir Pele and Michael Werman's implementation of the Earth Mover's Distance.")
+ (license license:expat)))
+
+(define-public python2-pyemd
+ (package-with-python2 python-pyemd))
+
(define-public python-pyev
(package
(name "python-pyev")