aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5ba92b2aa3..470bad84ff 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6936,13 +6936,13 @@ WebSocket usage in Python programs.")
(define-public python-atomicwrites
(package
(name "python-atomicwrites")
- (version "1.0.0")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "atomicwrites" version))
(sha256
(base32
- "019fa4771q7fb1167yfbh6msdzcqini6v7i59rmf72mzdjd7x5qv"))))
+ "1s01dci8arsl9d9vr5nz1fk9znldp1z3l4yl43f0c27z12b8yxl0"))))
(build-system python-build-system)
(synopsis "Atomic file writes in Python")
(description "Library for atomic file writes using platform dependent tools
@@ -8836,12 +8836,7 @@ LDFLAGS and parse the output to build extensions with setup.py.")
"126s53fkpx04f33a829yqqk8fj4png3qwg4m66cvlmhmwc8zihb4"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; python setup.py test does not work as of 0.98
- ;; but there is only the one test file
- (replace 'check
- (lambda _ (zero? (system* "python" "test_bz2file.py")))))))
+ `(#:tests? #f)) ; Tests use deprecated python modules.
(home-page "https://github.com/nvawda/bz2file")
(synopsis "Read and write bzip2-compressed files")
(description
@@ -8858,7 +8853,16 @@ development version of CPython that are not available in older releases.")
(package
(inherit base)
(native-inputs
- `(("python2-setuptools" ,python2-setuptools))))))
+ `(("python2-setuptools" ,python2-setuptools)))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; 'python setup.py test' does not work as of 0.98.
+ ;; There is only the one test file, so we run it directly.
+ (replace 'check
+ (lambda _ (zero? (system* "python"
+ "test_bz2file.py"))))))))))
(define-public python-cysignals
(package