aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7186c348fa..b65447113f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15064,3 +15064,33 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Unified diff parsing/metadata extraction library.")
(license license:expat)))
+
+(define-public python-testfixtures
+ (package
+ (name "python-testfixtures")
+ (version "5.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "testfixtures" version))
+ (sha256
+ (base32
+ "1w581221qbsmc177n7xijqn7wghyaaxxlwd2p34vfcn4jnbfv2ik"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-coverage" ,python-coverage)
+ ;("python-coveralls" ,python-coveralls)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ;("python-pytest-django" ,python-pytest-django)
+ ("python-sybil" ,python-sybil)
+ ("python-zope-component" ,python-zope-component)))
+ (home-page
+ "https://github.com/Simplistix/testfixtures")
+ (synopsis
+ "A collection of helpers and mock objects for unit tests and doc tests.")
+ (description
+ "A collection of helpers and mock objects for unit tests and doc tests.")
+ (license license:expat)))