aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm136
1 files changed, 122 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 82ff4cd95c..2c471fba58 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2017, 2020 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
@@ -31,7 +31,7 @@
;;; Copyright © 2016, 2017, 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016, 2017, 2018, 2020 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
@@ -50,7 +50,7 @@
;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
;;; Copyright © 2016, 2018 Tomáš Čech <sleep_walker@gnu.org>
-;;; Copyright © 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018, 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018, 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018, 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -93,6 +93,7 @@
;;; Copyright © 2020 Diego N. Barbato <dnbarbato@posteo.de>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
+;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -158,6 +159,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages openstack)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
@@ -175,6 +177,7 @@
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages terminals)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
@@ -1348,6 +1351,46 @@ abstractions to different hardware devices, and a suite of utilities for
sending and receiving messages on a CAN bus.")
(license license:lgpl3+)))
+(define-public python-caniusepython3
+ (package
+ (name "python-caniusepython3")
+ (version "7.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "caniusepython3" version))
+ (sha256
+ (base32
+ "0a755444ln38j8d7xb3yw0wzpd0mjrzfn6zqvsh06nw1vdaq4l28"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ;; These are for compatibility with Python 2.
+ ((".*'argparse', 'backports.functools_lru_cache',.*")
+ ""))
+ (substitute* "dev_requirements.txt"
+ ((".*pylint.*") "")) ;not actually required
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "py.test" "-k" "not NetworkTests"))))))
+ (propagated-inputs
+ `(("python-distlib" ,python-distlib)
+ ("python-packaging" ,python-packaging)
+ ("python-requests" ,python-requests)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/brettcannon/caniusepython3")
+ (synopsis "Check for Python 3-incompatible Python libraries")
+ (description "The @command{caniusepython3} command scans your project and
+reports the Python 3-incompatible libraries it found. It can also be used as
+a library.")
+ (license license:asl2.0)))
+
(define-public python-diskcache
(package
(name "python-diskcache")
@@ -4855,6 +4898,25 @@ algorithm. Patiencediff provides a good balance of performance, nice output for
humans, and implementation simplicity.")
(license license:gpl2)))
+(define-public python-pdftotext
+ (package
+ (name "python-pdftotext")
+ (version "2.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pdftotext" version))
+ (sha256
+ (base32
+ "19la1cw1hmkcr8big04gm2dd5fw0y0z97g930aiy29s1gaqbiblq"))))
+ (build-system python-build-system)
+ (inputs
+ `(("poppler" ,poppler)))
+ (home-page "https://github.com/jalan/pdftotext")
+ (synopsis "Simple PDF text extraction")
+ (description "Pdftotext is a Python library of PDF text extraction.")
+ (license license:expat)))
+
(define-public python-pyparsing
(package
(name "python-pyparsing")
@@ -13533,13 +13595,13 @@ collections of data.")
(define-public python-prompt-toolkit
(package
(name "python-prompt-toolkit")
- (version "3.0.7")
+ (version "3.0.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "prompt_toolkit" version))
(sha256
- (base32 "12a4pyrpnm3vcrvx7lb4cglp220lbvi336mhn2k2nzcgy82lcbw2"))))
+ (base32 "0bvjp62cs6aj9lrh7njzxdjgg8pjfw3qgmr551243d9ivmcapvn5"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -13556,8 +13618,7 @@ collections of data.")
`(("python-wcwidth" ,python-wcwidth)))
(native-inputs
`(("python-pytest" ,python-pytest)))
- (home-page
- "https://github.com/prompt-toolkit/python-prompt-toolkit")
+ (home-page "https://github.com/prompt-toolkit/python-prompt-toolkit")
(synopsis "Library for building command line interfaces in Python")
(description
"Prompt-Toolkit is a library for building interactive command line
@@ -14098,14 +14159,14 @@ monitors CPU, load, memory, network bandwidth, disk I/O, disk use, and more.")
(define-public python-graphql-core
(package
(name "python-graphql-core")
- (version "0.5.3")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "graphql-core" version))
(sha256
(base32
- "0rsaarx2sj4xnw9966rhh4haiqaapm4lm2mfqm48ywd51j5vh1a0"))))
+ "0fjv5w2wvgdr8gb27v241bavliipyir9fdz48rsgc3xapm644mn0"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; Tests require the unpackaged pytest-benchmark.
@@ -18169,13 +18230,13 @@ Included are implementations of:
(define-public bpython
(package
(name "bpython")
- (version "0.18")
+ (version "0.20.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "bpython" version))
(sha256
- (base32 "1hl6frgvr2lqaxqczl8amg9xih32b3gzv429vs0qrjb8wpdj1k2n"))))
+ (base32 "00vmkkc79mlnkyvwww1cr7bpwmf4p61704dhayz6kd0kc203hxvf"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -18198,11 +18259,14 @@ Included are implementations of:
(propagated-inputs
`(("python-pygments" ,python-pygments)
("python-requests" ,python-requests)
- ("python-babel" ,python-babel) ; optional, for internationalization
- ("python-curtsies" ,python-curtsies) ; >= 0.1.18
+ ("python-curtsies" ,python-curtsies)
("python-greenlet" ,python-greenlet)
+ ("python-six" ,python-six)
+ ("python-wcwidth" ,python-wcwidth)
+ ;; optional dependencies
("python-urwid" ,python-urwid) ; for bpython-urwid only
- ("python-six" ,python-six)))
+ ("python-watchdog" ,python-watchdog)
+ ("python-jedi" ,python-jedi)))
(native-inputs
`(("python-sphinx" ,python-sphinx)
("python-mock" ,python-mock)))
@@ -23337,3 +23401,47 @@ Qt applications.")
"Bitstring is a library for simple construction, analysis and modification
of binary data.")
(license license:expat)))
+
+(define-public python-pivy
+ (package
+ (name "python-pivy")
+ (version "0.6.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coin3d/pivy")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vids7sxk8w5vr73xdnf8xdci71a7syl6cd35aiisppbqyyfmykx"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; The test suite fails due to an import cycle between 'pivy' and '_coin'
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-cmake-include-dirs
+ (lambda _
+ ;; Patch buildsystem to respect Coin3D include directory
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{SoQt_INCLUDE_DIRS}")
+ "${Coin_INCLUDE_DIR};${SoQt_INCLUDE_DIRS}"))
+ #t)))))
+ (native-inputs
+ `(("cmake" ,cmake)
+ ("swig" ,swig)))
+ (inputs
+ `(("python-wrapper" ,python-wrapper)
+ ("qtbase" ,qtbase)
+ ("libxi" ,libxi)
+ ("libice" ,libice)
+ ("soqt" ,soqt)
+ ("glew" ,glew)
+ ("coin3D" ,coin3D-4)))
+ (home-page "https://github.com/coin3d/pivy")
+ (synopsis "Python bindings to Coin3D")
+ (description
+ "Pivy provides python bindings for Coin, a 3D graphics library with an
+Application Programming Interface based on the Open Inventor 2.1 API.")
+ (license license:isc)))