aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 572d48b0de..209bf5a6bc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4995,10 +4995,17 @@ that client code uses to construct the grammar directly in Python code.")
"Numpy's Sphinx extensions")
(description
"Sphinx extension to support docstrings in Numpy format.")
- (license license:bsd-2)))
+ (license license:bsd-2)
+ (properties `((python2-variant . ,(delay python2-numpydoc))))))
(define-public python2-numpydoc
- (package-with-python2 python-numpydoc))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-numpydoc))))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python2-jinja2" ,python2-jinja2)
+ ,@(package-propagated-inputs base))))))
(define-public python-numexpr
(package