aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9cf9fe8c17..12f8dc40da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23555,6 +23555,28 @@ Qt applications.")
of binary data.")
(license license:expat)))
+(define-public python-confuse
+ (package
+ (name "python-confuse")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "confuse" version))
+ (sha256
+ (base32
+ "0r74djc8r6lfx6ldsqnhpvfsn256gsfzbl33qcm77hp2qr8h9z4j"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pathlib" ,python-pathlib)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page "https://github.com/beetbox/confuse")
+ (synopsis "Painless YAML configuration.")
+ (description "Confuse is a configuration library for Python that uses
+YAML. It takes care of defaults, overrides, type checking, command-line
+integration, human-readable errors, and standard OS-specific locations.")
+ (license license:expat)))
+
(define-public python-pivy
(package
(name "python-pivy")