aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a2178bf5d5..f8ca2242ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17038,12 +17038,19 @@ scans through a file and detects issues.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-completion-test
+ (lambda _
+ ;; This resolves a failure in the 'test_completion' test (see:
+ ;; https://github.com/davidhalter/jedi/issues/1824).
+ ;; TODO: Remove after a new release is made (currently: 0.18.1).
+ (substitute* "test/completion/lambdas.py"
+ (("\\[a for a in \\[1,2\\] if lambda: 3\\]\\[0\\]")
+ "[a for a in [1,2] if (lambda: 3)][0]"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(setenv "HOME" "/tmp")
- (invoke "python" "-m" "pytest" "-vv"))
- #t)))))
+ (invoke "python" "-m" "pytest" "-vv")))))))
(native-inputs
(list python-colorama python-docopt python-pytest))
(propagated-inputs