aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pth.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pth.scm')
-rw-r--r--gnu/packages/pth.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/pth.scm b/gnu/packages/pth.scm
index 5b8edc6cfb..1908ce7763 100644
--- a/gnu/packages/pth.scm
+++ b/gnu/packages/pth.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,7 +38,12 @@
"0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
(build-system gnu-build-system)
(arguments
- '(#:parallel-build? #f))
+ `(#:parallel-build? #f
+ #:configure-flags (list
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '()))))
(home-page "https://www.gnu.org/software/pth/")
(synopsis "Portable thread library")
(description