aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 586e532746..f4e9e88233 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -70,10 +70,7 @@ internal RPC protocols and file formats.")
(description
"Protocol buffers are a language-neutral, platform-neutral extensible
mechanism for serializing structured data.")
- (license bsd-3)
- (properties `((python2-variant . ,(delay python2-protobuf))))))
+ (license bsd-3)))
(define-public python2-protobuf
- (package (inherit (package-with-python2
- (strip-python2-variant python-protobuf)))
- (native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+ (package-with-python2 python-protobuf))