aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm30
1 files changed, 20 insertions, 10 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 6dcf1675c4..7bc54c4a0b 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -166,28 +167,37 @@ different programming languages.")
(define-public fmt
(package
(name "fmt")
- (version "8.1.1")
+ (version "9.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
version "/fmt-" version ".zip"))
(sha256
- (base32 "0p8f82ijqa57sk72hjf0qviv1wwinmns0p87wiv2v8fvisnqnxr3"))))
+ (base32 "15n9yi6xzzs7g9rm87kg8y5yhl2zrqj3bjr845saa63f6swlrsyc"))))
(build-system cmake-build-system)
- (arguments
- '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
- (native-inputs
- (list unzip))
+ (arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+ (native-inputs (list unzip))
(home-page "https://fmt.dev")
(synopsis "Small and fast C++ formatting library")
- (description
- "@code{fmt} (formerly @code{cppformat}) is a formatting library for C++.
-It can be used as a safe alternative to @code{printf} or as a fast alternative
-to @code{IOStreams}.")
+ (description "@code{fmt} (formerly @code{cppformat}) is a formatting
+library for C++. It can be used as a safe alternative to @code{printf} or as
+a fast alternative to @code{IOStreams}.")
;; The library is bsd-2, but documentation and tests include other licenses.
(license (list bsd-2 bsd-3 psfl))))
+(define-public fmt-8
+ (package
+ (inherit fmt)
+ (version "8.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
+ version "/fmt-" version ".zip"))
+ (sha256
+ (base32 "0p8f82ijqa57sk72hjf0qviv1wwinmns0p87wiv2v8fvisnqnxr3"))))))
+
(define-public fmt-8.0
(package
(inherit fmt)