aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 5ffe7c8999..a96f1c2259 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -2,6 +2,8 @@
;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -124,6 +126,7 @@
"--with-mysqli" ; Required for, e.g. wordpress
"--with-pdo-mysql"
"--with-zlib"
+ "--enable-bcmath" ; Required for, e.g. Zabbix frontend
"--enable-calendar"
"--enable-dba=shared"
"--enable-exif"
@@ -351,10 +354,4 @@ systems, web content management systems and web frameworks." )
license:expat)))) ; ext/date/lib
(define-public php-with-bcmath
- (package
- (inherit php)
- (name "php-with-bcmath")
- (arguments
- (substitute-keyword-arguments (package-arguments php)
- ((#:configure-flags flags)
- `(cons "--enable-bcmath" ,flags))))))
+ (deprecated-package "php-with-bcmath" php))