aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index f227786e8d..a8b4248a1b 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -331,11 +331,12 @@ deserializing JSON.")
(synopsis "Provide simple serialisation/deserialisation of objects to/from JSON")
(description "This is a simple role that provides methods to instantiate a
class from a JSON string that (hopefully,) represents it, and to serialise an
-object of the class to a JSON string. The JSON created from an instance should
-round trip to a new instance with the same values for the @quot{public
-attributes}. @quot{Private} attributes (that is ones without accessors,) will
-be ignored for both serialisation and de-serialisation. The exact behaviour
-depends on that of @code{JSON::Marshal} and @code{JSON::Unmarshal} respectively.")
+object of the class to a JSON string. The JSON created from an instance
+should round trip to a new instance with the same values for the public
+attributes. Private attributes (that is ones without accessors,) will be
+ignored for both serialisation and de-serialisation. The exact behaviour
+depends on that of @code{JSON::Marshal} and @code{JSON::Unmarshal}
+respectively.")
(license license:artistic2.0)))
(define-public perl6-json-fast