aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm32
1 files changed, 10 insertions, 22 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 96773da717..5df7385e78 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -79,15 +79,15 @@
(define-public poppler
(package
(name "poppler")
- (version "0.59.0")
+ (version "0.62.0")
(source (origin
(method url-fetch)
(uri (string-append "https://poppler.freedesktop.org/poppler-"
version ".tar.xz"))
(sha256
(base32
- "0hcnghliyr8pr887qza18qfgaclw5jr889g1cjcglkni9jr2dmm3"))))
- (build-system gnu-build-system)
+ "1ii9ly1pngyvs0aiq2wxpya08hidpl54y7nsb8b1vxnnskgp76jv"))))
+ (build-system cmake-build-system)
;; FIXME:
;; use libcurl: no
(inputs `(("fontconfig" ,fontconfig)
@@ -96,7 +96,7 @@
("libpng" ,libpng)
("libtiff" ,libtiff)
("lcms" ,lcms)
- ("openjpeg-1" ,openjpeg-1) ; prefers openjpeg-1
+ ("openjpeg" ,openjpeg)
("zlib" ,zlib)
;; To build poppler-glib (as needed by Evince), we need Cairo and
@@ -112,20 +112,12 @@
(arguments
`(#:tests? #f ; no test data provided with the tarball
#:configure-flags
- '("--enable-xpdf-headers" ; to install header files
- "--enable-zlib"
-
- ;; Saves 8 MiB of .a files.
- "--disable-static")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'setenv
- (lambda _
- (setenv "CPATH"
- (string-append (assoc-ref %build-inputs "openjpeg-1")
- "/include/openjpeg-1.5"
- ":" (or (getenv "CPATH") "")))
- #t)))))
+ (let* ((out (assoc-ref %outputs "out"))
+ (lib (string-append out "/lib")))
+ (list "-DENABLE_XPDF_HEADERS=ON" ; to install header files
+ "-DENABLE_ZLIB=ON"
+ (string-append "-DCMAKE_INSTALL_LIBDIR=" lib)
+ (string-append "-DCMAKE_INSTALL_RPATH=" lib)))))
(synopsis "PDF rendering library")
(description
"Poppler is a PDF rendering library based on the xpdf-3.0 code base.")
@@ -144,10 +136,6 @@
(name "poppler-qt5")
(inputs `(("qtbase" ,qtbase)
,@(package-inputs poppler)))
- (arguments
- (substitute-keyword-arguments (package-arguments poppler)
- ((#:configure-flags flags)
- `(cons "CXXFLAGS=-std=gnu++11" ,flags))))
(synopsis "Qt5 frontend for the Poppler PDF rendering library")))
(define-public python-poppler-qt4