aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm34
1 files changed, 20 insertions, 14 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index a68e369912..fa5ad62e44 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -31,17 +31,19 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages file)
#:use-module (gnu packages gawk)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages less)
#:use-module (gnu packages mail)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages xml))
(define-public patchutils
(package
(name "patchutils")
- (version "0.3.3")
+ (version "0.3.4")
(source
(origin
(method url-fetch)
@@ -49,8 +51,8 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "0g5df00cj4nczrmr4k791l7la0sq2wnf8rn981fsrz1f3d2yix4i"))
- (patches (search-patches "patchutils-xfail-gendiff-tests.patch"))))
+ "0xp8mcfyi5nmb5a2zi5ibmyshxkb1zv1dgmnyn413m7ahgdx8mfg"))
+ (patches (search-patches "patchutils-test-perms.patch"))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)))
(arguments
@@ -59,10 +61,8 @@
(modify-phases %standard-phases
(add-before 'check 'patch-test-scripts
(lambda _
- (let ((echo (which "echo")))
- (substitute*
- (find-files "tests" "^run-test$")
- (("/bin/echo") echo)))
+ (substitute* (find-files "tests" "^run-test$")
+ (("/bin/echo") (which "echo")))
#t))
(add-after 'install 'wrap-program
;; Point installed scripts to the utilities they need.
@@ -92,7 +92,7 @@ listing the files modified by a patch.")
(define-public quilt
(package
(name "quilt")
- (version "0.61")
+ (version "0.65")
(source
(origin
(method url-fetch)
@@ -100,12 +100,18 @@ listing the files modified by a patch.")
name "-" version ".tar.gz"))
(sha256
(base32
- "1hwz58djkq9cv46sjwxbp2v5m8yjr41kd0nm1zm1xm6418khmv0y"))))
+ "06b816m2gz9jfif7k9v2hrm7fz76zjg5pavf7hd3ifybwn4cgjzn"))
+ (patches (search-patches "quilt-test-fix-regex.patch"
+ "quilt-compat-getopt-fix-second-separator.patch"
+ "quilt-compat-getopt-fix-option-with-nondigit-param.patch"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gnu-gettext)))
(inputs `(("perl" ,perl)
("less" ,less)
("file" ,file)
- ("ed" ,ed)))
+ ("ed" ,ed)
+ ("diffstat" ,diffstat)))
(arguments
'(#:parallel-tests? #f
#:phases
@@ -116,8 +122,6 @@ listing the files modified by a patch.")
'("test/run"
"test/edit.test")
(("/bin/sh") (which "sh")))
- ;; TODO: Run the mail tests once the mail feature can be supported.
- (delete-file "test/mail.test")
#t))
(add-after 'install 'wrap-program
;; quilt's configure checks for the absolute path to the utilities it
@@ -128,6 +132,7 @@ listing the files modified by a patch.")
(coreutils (assoc-ref inputs "coreutils"))
(diffutils (assoc-ref inputs "diffutils"))
(findutils (assoc-ref inputs "findutils"))
+ (diffstat (assoc-ref inputs "diffstat"))
(less (assoc-ref inputs "less"))
(file (assoc-ref inputs "file"))
(ed (assoc-ref inputs "ed"))
@@ -139,7 +144,8 @@ listing the files modified by a patch.")
,(map (lambda (dir)
(string-append dir "/bin"))
(list coreutils diffutils findutils
- less file ed sed bash grep)))))
+ less file ed sed bash grep
+ diffstat)))))
#t)))))
(home-page "https://savannah.nongnu.org/projects/quilt/")
(synopsis "Script for managing patches to software")