aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/git-filter-repo-generate-doc.patch88
-rw-r--r--gnu/packages/patches/guile-git-adjust-for-libgit2-1.2.0.patch78
-rw-r--r--gnu/packages/patches/librime-fix-build-with-gcc10.patch41
-rw-r--r--gnu/packages/patches/wlroots-hwdata-fallback.patch46
4 files changed, 134 insertions, 119 deletions
diff --git a/gnu/packages/patches/git-filter-repo-generate-doc.patch b/gnu/packages/patches/git-filter-repo-generate-doc.patch
new file mode 100644
index 0000000000..4535ae5bc4
--- /dev/null
+++ b/gnu/packages/patches/git-filter-repo-generate-doc.patch
@@ -0,0 +1,88 @@
+From 56e6857e71d2b2a2236625f3c8b112bd40a8b164 Mon Sep 17 00:00:00 2001
+From: Josselin Poiret <dev@jpoiret.xyz>
+Date: Fri, 16 Feb 2024 00:21:06 +0800
+Subject: [PATCH] Add documentation generation.
+
+This requires the manpage XSL and asciidoc config files from git 2.41.0.
+
+Modified-by: Hilton Chain <hako@ultrarare.space>
+---
+ Documentation/Makefile | 34 ++++++++++++++++++++++++++++++++++
+ Makefile | 17 +++--------------
+ 2 files changed, 37 insertions(+), 14 deletions(-)
+ create mode 100644 Documentation/Makefile
+
+diff --git a/Documentation/Makefile b/Documentation/Makefile
+new file mode 100644
+index 0000000..d81ffbe
+--- /dev/null
++++ b/Documentation/Makefile
+@@ -0,0 +1,34 @@
++MAN_BASE_URL := $(prefix)/share/doc/git-doc/
++VERSION := $(git log --pretty="%H" -n 1)
++
++ASCIIDOC := asciidoc
++ASCIIDOC_EXTRA :=
++ASCIIDOC_HTML := xhtml11
++ASCIIDOC_DOCBOOK := docbook
++ASCIIDOC_CONF := -f asciidoc.conf
++ASCIIDOC_COMMON := $(ASCIIDOC) $(ASCIIDOC_EXTRA) $(ASCIIDOC_CONF) \
++ -amanmanual='git-filter-repo Manual' -amansource='git-filter-repo $(VERSION)'
++ASCIIDOC_DEPS := asciidoc.conf
++TXT_TO_HTML := $(ASCIIDOC_COMMON) -b $(ASCIIDOC_HTML)
++TXT_TO_XML := $(ASCIIDOC_COMMON) -b $(ASCIIDOC_DOCBOOK)
++MANPAGE_XSL := manpage-normal.xsl
++XMLTO := xmlto
++XMLTO_EXTRA := -m manpage-bold-literal.xsl \
++ --stringparam man.base.url.for.relative.links='$(MAN_BASE_URL)'
++
++manpage-prereqs := $(wildcard manpage*.xsl)
++manpage-cmd := $(XMLTO) -m $(MANPAGE_XSL) $(XMLTO_EXTRA) man
++
++%.xml : %.txt $(ASCIIDOC_DEPS)
++ $(TXT_TO_XML) -d manpage -o $@ $<
++
++man1/%.1 : %.xml $(manpage-prereqs)
++ mkdir -p man1
++ $(manpage-cmd) -o man1 $<
++
++html/%.html : %.txt $(ASCIIDOC_DEPS)
++ mkdir -p html
++ $(TXT_TO_HTML) -d manpage -o $@ $<
++
++man: man1/git-filter-repo.1
++html: html/git-filter-repo.html
+diff --git a/Makefile b/Makefile
+index a443450..d965ae5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -20,21 +20,10 @@ test:
+ fixup_locale:
+ sed -ie s%@@LOCALEDIR@@%$(localedir)% git-filter-repo
+
+-# People installing from tarball will already have man1/git-filter-repo.1 and
+-# html/git-filter-repo.html. But let's support people installing from a git
+-# clone too; for them, just cheat and snag a copy of the built docs that I
+-# record in a different branch.
+-snag_docs: Documentation/man1/git-filter-repo.1 Documentation/html/git-filter-repo.html
++doc:
++ $(MAKE) -C Documentation man html
+
+-Documentation/man1/git-filter-repo.1:
+- mkdir -p Documentation/man1
+- git show origin/docs:man1/git-filter-repo.1 >Documentation/man1/git-filter-repo.1
+-
+-Documentation/html/git-filter-repo.html:
+- mkdir -p Documentation/html
+- git show origin/docs:html/git-filter-repo.html >Documentation/html/git-filter-repo.html
+-
+-install: snag_docs #fixup_locale
++install: doc #fixup_locale
+ install -Dm0755 git-filter-repo "$(DESTDIR)/$(bindir)/git-filter-repo"
+ install -dm0755 "$(DESTDIR)/$(pythondir)"
+ ln -sf "$(bindir)/git-filter-repo" "$(DESTDIR)/$(pythondir)/git_filter_repo.py"
+
+base-commit: cbc6535694380d3a3bf3e5c96410d4ce7e8de94f
+--
+2.41.0
+
diff --git a/gnu/packages/patches/guile-git-adjust-for-libgit2-1.2.0.patch b/gnu/packages/patches/guile-git-adjust-for-libgit2-1.2.0.patch
deleted file mode 100644
index 436a11ad19..0000000000
--- a/gnu/packages/patches/guile-git-adjust-for-libgit2-1.2.0.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 107e6ca..20e9019 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2,6 +2,7 @@ dnl Guile-Git --- GNU Guile bindings of libgit2
- dnl Copyright © 2016-2018 Erik Edrosa <erik.edrosa@gmail.com>
- dnl Copyright © 2017, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
- dnl Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
-+dnl Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
- dnl
- dnl This file is part of Guile-Git.
- dnl
-@@ -43,15 +44,20 @@ AS_IF([test "x$LIBGIT2_LIBDIR" = "x"], [
- ])
- AC_SUBST([LIBGIT2_LIBDIR])
-
-+dnl Does the 'git_remote_callbacks' struct have a 'remote_ready' field?
-+dnl It was added in 1.2.0, obsoleting 'resolve_url'.
-+AC_CHECK_MEMBER([git_remote_callbacks.remote_ready],
-+ [HAVE_REMOTE_CALLBACKS_REMOTE_READY="#true"],
-+ [HAVE_REMOTE_CALLBACKS_REMOTE_READY="#false"],
-+ [[#include <git2.h>]])
-+AC_SUBST([HAVE_REMOTE_CALLBACKS_REMOTE_READY])
-+
- dnl Does the 'git_remote_callbacks' struct have a 'resolve_url' field?
- dnl It's missing in libgit2 0.28.5, added in 1.0.
--AC_CHECK_MEMBER([git_remote_callbacks.resolve_url], [], [],
-+AC_CHECK_MEMBER([git_remote_callbacks.resolve_url],
-+ [HAVE_REMOTE_CALLBACKS_RESOLVE_URL="#true"],
-+ [HAVE_REMOTE_CALLBACKS_RESOLVE_URL="#false"],
- [[#include <git2.h>]])
--if test "x$ac_cv_member_git_remote_callbacks_resolve_url" = "xyes"; then
-- HAVE_REMOTE_CALLBACKS_RESOLVE_URL="#true"
--else
-- HAVE_REMOTE_CALLBACKS_RESOLVE_URL="#false"
--fi
- AC_SUBST([HAVE_REMOTE_CALLBACKS_RESOLVE_URL])
-
- dnl Those binaries are required for ssh authentication tests.
-diff --git a/git/configuration.scm.in b/git/configuration.scm.in
-index c45f698..64c4360 100644
---- a/git/configuration.scm.in
-+++ b/git/configuration.scm.in
-@@ -19,11 +19,17 @@
-
- (define-module (git configuration)
- #:export (%libgit2
-+ %have-remote-callbacks-remote-ready?
- %have-remote-callbacks-resolve-url?))
-
- (define %libgit2
- "@LIBGIT2_LIBDIR@/libgit2")
-
-+(define %have-remote-callbacks-remote-ready?
-+ ;; True if the 'git_remote_callbacks' struct has a
-+ ;; 'remote_ready' field.
-+ @HAVE_REMOTE_CALLBACKS_REMOTE_READY@)
-+
- (define %have-remote-callbacks-resolve-url?
- ;; True if the 'git_remote_callbacks' struct has a 'resolve_url' field.
- @HAVE_REMOTE_CALLBACKS_RESOLVE_URL@)
-diff --git a/git/structs.scm b/git/structs.scm
-index ca51728..be3d050 100644
---- a/git/structs.scm
-+++ b/git/structs.scm
-@@ -637,6 +637,12 @@ type to 'specified for this to take effect."
- (push-update-reference ,(bs:pointer uint8))
- (push-negotiation ,(bs:pointer uint8))
- (transport ,(bs:pointer uint8))
-+
-+ ;; Added in libgit2 1.2.0.
-+ ,@(if %have-remote-callbacks-remote-ready?
-+ `((remote-ready ,(bs:pointer uint8)))
-+ '())
-+
- (payload ,(bs:pointer uint8))
-
- ;; libgit2 1.0 added this field, which is missing from 0.28.5,
diff --git a/gnu/packages/patches/librime-fix-build-with-gcc10.patch b/gnu/packages/patches/librime-fix-build-with-gcc10.patch
deleted file mode 100644
index 49ad011b57..0000000000
--- a/gnu/packages/patches/librime-fix-build-with-gcc10.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From: Felix Gruber <felgru@posteo.net>
-Date: Mon, 6 Sep 2021 19:38:17 +0200
-Subject: [PATCH] Add missing <cmath> includes
-
-Fix a build failure with GCC 10 that manifests like this:
-
-------
-/tmp/guix-build-librime-1.7.3.drv-0/source/src/rime/gear/script_translator.cc: In member function ‘void rime::ScriptTranslation::PrepareCandidate()’:
-/tmp/guix-build-librime-1.7.3.drv-0/source/src/rime/gear/script_translator.cc:490:23: error: ‘exp’ was not declared in this scope
- 490 | cand->set_quality(exp(entry->weight) +
- | ^~~
-/tmp/guix-build-librime-1.7.3.drv-0/source/src/rime/gear/script_translator.cc:504:23: error: ‘exp’ was not declared in this scope
- 504 | cand->set_quality(exp(entry->weight) +
- | ^~~
-make[2]: *** [src/CMakeFiles/rime.dir/build.make:1241: src/CMakeFiles/rime.dir/rime/gear/script_translator.cc.o] Error 1
-------
-
-diff --git a/src/rime/gear/script_translator.cc b/src/rime/gear/script_translator.cc
-index 4a45f05..515c8db 100644
---- a/src/rime/gear/script_translator.cc
-+++ b/src/rime/gear/script_translator.cc
-@@ -7,6 +7,7 @@
- // 2011-07-10 GONG Chen <chen.sst@gmail.com>
- //
- #include <algorithm>
-+#include <cmath>
- #include <stack>
- #include <boost/algorithm/string/join.hpp>
- #include <boost/range/adaptor/reversed.hpp>
-diff --git a/src/rime/gear/table_translator.cc b/src/rime/gear/table_translator.cc
-index 162ac02..dbea76a 100644
---- a/src/rime/gear/table_translator.cc
-+++ b/src/rime/gear/table_translator.cc
-@@ -4,6 +4,7 @@
- //
- // 2011-07-10 GONG Chen <chen.sst@gmail.com>
- //
-+#include <cmath>
- #include <boost/algorithm/string.hpp>
- #include <boost/range/adaptor/reversed.hpp>
- #include <utf8.h>
diff --git a/gnu/packages/patches/wlroots-hwdata-fallback.patch b/gnu/packages/patches/wlroots-hwdata-fallback.patch
new file mode 100644
index 0000000000..6468c7cbf3
--- /dev/null
+++ b/gnu/packages/patches/wlroots-hwdata-fallback.patch
@@ -0,0 +1,46 @@
+backend/drm: add hardcoded hwdata path fallback
+
+Add hardcoded fallback "/usr/share/hwdata/pnp.ids" as a
+temporary solution to get things working in Guix until
+hwdata ships with pkg-config file.
+
+diff --git a/backend/drm/meson.build b/backend/drm/meson.build
+index 6fcb2c15..ed95360a 100644
+--- a/backend/drm/meson.build
++++ b/backend/drm/meson.build
+@@ -1,8 +1,7 @@
+ hwdata = dependency(
+ 'hwdata',
+- required: 'drm' in backends,
++ required: false,
+ native: true,
+- not_found_message: 'Required for the DRM backend.',
+ )
+
+ libdisplay_info = dependency(
+@@ -19,15 +18,21 @@ libliftoff = dependency(
+ required: false,
+ )
+
+-if not (hwdata.found() and libdisplay_info.found() and features['session'])
++if hwdata.found()
++ hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
++ pnp_ids = files(hwdata_dir / 'pnp.ids')
++else
++ pnp_ids = files('/usr/share/hwdata/pnp.ids')
++endif
++
++if not (libdisplay_info.found() and features['session'])
+ subdir_done()
+ endif
+
+-hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
+ pnpids_c = custom_target(
+ 'pnpids.c',
+ output: 'pnpids.c',
+- input: files(hwdata_dir / 'pnp.ids'),
++ input: pnp_ids,
+ feed: true,
+ capture: true,
+ command: files('gen_pnpids.sh'),
+