aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/fastcap-mulGlobal.patch13
-rw-r--r--gnu/packages/patches/fastcap-mulSetup.patch19
2 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/patches/fastcap-mulGlobal.patch b/gnu/packages/patches/fastcap-mulGlobal.patch
new file mode 100644
index 0000000000..efb3b570db
--- /dev/null
+++ b/gnu/packages/patches/fastcap-mulGlobal.patch
@@ -0,0 +1,13 @@
+Don't use timing as there is a type conflict.
+
+--- nix-build-fastcap-2.0-18Sep92.drv-1/src/mulGlobal.h.orig 2015-07-21 15:58:49.199101566 +0200
++++ nix-build-fastcap-2.0-18Sep92.drv-1/src/mulGlobal.h 2015-07-21 16:18:39.456751313 +0200
+@@ -57,7 +57,7 @@
+ /* time variables/structs */
+ #ifndef _TIME_ /* if not on a Sun4 */
+ #ifndef NEWS /* if not on a NWS-38XX */
+-#include <time.h>
++//#include <time.h>
+ #endif
+ #endif
+
diff --git a/gnu/packages/patches/fastcap-mulSetup.patch b/gnu/packages/patches/fastcap-mulSetup.patch
new file mode 100644
index 0000000000..00eb7e96b5
--- /dev/null
+++ b/gnu/packages/patches/fastcap-mulSetup.patch
@@ -0,0 +1,19 @@
+Add forward declarations.
+
+--- fastcap/src/mulSetup.c.orig 2015-07-22 13:55:21.592119775 +0200
++++ fastcap/src/mulSetup.c 2015-07-22 14:08:50.157688209 +0200
+@@ -35,6 +35,14 @@
+
+ #include "mulGlobal.h"
+
++static getnbrs(ssystem*);
++static linkcubes(ssystem*);
++static setMaxq(ssystem*);
++static getAllInter(ssystem*);
++static set_vector_masks(ssystem*);
++static indexkid(ssystem*, cube*, int*, int*);
++static int placeq(int, ssystem*, charge*);
++
+ cube *cstack[1024]; /* Stack used in several routines. */
+
+ /*