aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch b/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
new file mode 100644
index 0000000000..ccc9c09fb9
--- /dev/null
+++ b/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
@@ -0,0 +1,14 @@
+Don't check whether gnuplot is present in $PATH, because we know it is.
+
+diff --git a/eazy-gnuplot.asd b/eazy-gnuplot.asd
+index 7b1c09b..4657cd6 100644
+--- a/eazy-gnuplot.asd
++++ b/eazy-gnuplot.asd
+@@ -37,7 +37,4 @@
+ :fill-pointer t)))
+ (setf (fill-pointer seq) (read-sequence seq stream))
+ seq)))
+- :perform (load-op :before (op c)
+- (unless (zerop (nth-value 2 (uiop:run-program "which gnuplot" :ignore-error-status t)))
+- (warn "Could not find GNUPLOT in $PATH")))
+ :in-order-to ((test-op (test-op eazy-gnuplot.test))))