aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/x265-detect512-all-arches.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/x265-detect512-all-arches.patch')
-rw-r--r--gnu/packages/patches/x265-detect512-all-arches.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/patches/x265-detect512-all-arches.patch b/gnu/packages/patches/x265-detect512-all-arches.patch
deleted file mode 100644
index 4d39d868fd..0000000000
--- a/gnu/packages/patches/x265-detect512-all-arches.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://sources.debian.org/data/main/x/x265/2.9-3/debian/patches/0003-detect512-is-needed-on-all-architectures.patch
-
-From: Adam Sampson <unknown@bitbucket>
-Date: Sun, 14 Oct 2018 14:04:18 +0200
-Subject: detect512 is needed on all architectures
-
----
- source/common/cpu.cpp | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/source/common/cpu.cpp b/source/common/cpu.cpp
-index 0681ff5..fa687da 100644
---- a/source/common/cpu.cpp
-+++ b/source/common/cpu.cpp
-@@ -110,6 +110,11 @@ const cpu_name_t cpu_names[] =
- { "", 0 },
- };
-
-+bool detect512()
-+{
-+ return(enable512);
-+}
-+
- #if X265_ARCH_X86
-
- extern "C" {
-@@ -123,10 +128,6 @@ uint64_t PFX(cpu_xgetbv)(int xcr);
- #pragma warning(disable: 4309) // truncation of constant value
- #endif
-
--bool detect512()
--{
-- return(enable512);
--}
- uint32_t cpu_detect(bool benableavx512 )
- {
-