aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-louvain-fix-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-louvain-fix-test.patch')
-rw-r--r--gnu/packages/patches/python-louvain-fix-test.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-louvain-fix-test.patch b/gnu/packages/patches/python-louvain-fix-test.patch
new file mode 100644
index 0000000000..2127df681c
--- /dev/null
+++ b/gnu/packages/patches/python-louvain-fix-test.patch
@@ -0,0 +1,15 @@
+https://github.com/taynaud/python-louvain/commit/638804ae636dc65306900ef6518ca0a1c9202566.diff
+
+diff --git a/test_community.py b/test_community.py
+index 1ee1976..566a4b1 100644
+--- a/test_community.py
++++ b/test_community.py
+@@ -203,7 +203,7 @@ def test_karate(self):
+ self.assertAlmostEqual(co.modularity(part, graph),
+ co.modularity(part_weight,
+ graph,
+- "test_weight"), places=2)
++ "test_weight"), places=1)
+
+ part_res_low = co.best_partition(graph, resolution=0.1)
+ self.assertTrue(