aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/openscad-with-cgal-5.3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/openscad-with-cgal-5.3.patch')
-rw-r--r--gnu/packages/patches/openscad-with-cgal-5.3.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/patches/openscad-with-cgal-5.3.patch b/gnu/packages/patches/openscad-with-cgal-5.3.patch
new file mode 100644
index 0000000000..dc3c1caa3b
--- /dev/null
+++ b/gnu/packages/patches/openscad-with-cgal-5.3.patch
@@ -0,0 +1,47 @@
+From 9aa0d7e9f2914fe5f547bdde69202161d1c6064d Mon Sep 17 00:00:00 2001
+From: Jordan Brown <github@jordan.maileater.net>
+Date: Sun, 18 Jul 2021 21:01:46 -0700
+Subject: [PATCH] Fix build failure with "generic_print_polyhedron" on
+ CGAL-5.3.
+
+---
+ src/cgalutils-polyhedron.cc | 13 -------------
+ src/cgalutils.h | 1 -
+ 2 files changed, 14 deletions(-)
+
+diff --git a/src/cgalutils-polyhedron.cc b/src/cgalutils-polyhedron.cc
+index 9f4f98f623..41cca4b3f2 100644
+--- a/src/cgalutils-polyhedron.cc
++++ b/src/cgalutils-polyhedron.cc
+@@ -337,19 +337,6 @@ namespace CGALUtils {
+ }
+ };
+
+- template <typename Polyhedron>
+- std::string printPolyhedron(const Polyhedron &p) {
+- std::ostringstream sstream;
+- sstream.precision(20);
+-
+- Polyhedron_writer writer;
+- generic_print_polyhedron(sstream, p, writer);
+-
+- return sstream.str();
+- }
+-
+- template std::string printPolyhedron(const CGAL_Polyhedron &p);
+-
+ }; // namespace CGALUtils
+
+ #endif /* ENABLE_CGAL */
+diff --git a/src/cgalutils.h b/src/cgalutils.h
+index 21a01cdba6..c08a3aa7df 100644
+--- a/src/cgalutils.h
++++ b/src/cgalutils.h
+@@ -45,7 +45,6 @@ namespace CGALUtils {
+ bool is_approximately_convex(const PolySet &ps);
+ Geometry const* applyMinkowski(const Geometry::Geometries &children);
+
+- template <typename Polyhedron> std::string printPolyhedron(const Polyhedron &p);
+ template <typename Polyhedron> bool createPolySetFromPolyhedron(const Polyhedron &p, PolySet &ps);
+ template <typename Polyhedron> bool createPolyhedronFromPolySet(const PolySet &ps, Polyhedron &p);
+ template <class Polyhedron_A, class Polyhedron_B>