aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/onionshare-cli-async-mode.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/onionshare-cli-async-mode.patch')
-rw-r--r--gnu/packages/patches/onionshare-cli-async-mode.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/onionshare-cli-async-mode.patch b/gnu/packages/patches/onionshare-cli-async-mode.patch
new file mode 100644
index 0000000000..b71b56046d
--- /dev/null
+++ b/gnu/packages/patches/onionshare-cli-async-mode.patch
@@ -0,0 +1,25 @@
+Specifying the `async_mode` parameter seems to have been a workaround for
+packaging on Windows and macOS. If not given, flask_socketio.SocketIO will
+probe for an available asynchronous model, e.g. `eventlet`, and otherwise gets
+stuck if `gevent-socketio` is not available.
+
+c.f. https://github.com/onionshare/onionshare/commit/ec7fa4ef16c9e1ba6028ee927c23f76c399a17a6
+and https://github.com/onionshare/onionshare/issues/1510
+
+diff --git a/cli/onionshare_cli/web/web.py b/cli/onionshare_cli/web/web.py
+index 64844b5..7e1b095 100644
+--- a/cli/onionshare_cli/web/web.py
++++ b/cli/onionshare_cli/web/web.py
+@@ -164,10 +164,10 @@ class Web:
+ elif self.mode == "chat":
+ if self.common.verbose:
+ self.socketio = SocketIO(
+- async_mode="gevent", logger=True, engineio_logger=True
++ logger=True, engineio_logger=True
+ )
+ else:
+- self.socketio = SocketIO(async_mode="gevent")
++ self.socketio = SocketIO()
+ self.socketio.init_app(self.app)
+ self.chat_mode = ChatModeWeb(self.common, self)
+