aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/nfs-utils-missing-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/nfs-utils-missing-headers.patch')
-rw-r--r--gnu/packages/patches/nfs-utils-missing-headers.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/nfs-utils-missing-headers.patch b/gnu/packages/patches/nfs-utils-missing-headers.patch
new file mode 100644
index 0000000000..7f0542836e
--- /dev/null
+++ b/gnu/packages/patches/nfs-utils-missing-headers.patch
@@ -0,0 +1,19 @@
+Fix compilation failure with glibc 2.26 caused by missing type
+declarations:
+
+------
+rpc.c: In function ‘nsm_recv_getport’:
+rpc.c:469:13: error: ‘UINT16_MAX’ undeclared (first use in this function)
+ if (port > UINT16_MAX) {
+------
+
+--- a/support/nsm/rpc.c.orig 2016-08-03 20:25:15.000000000 +0200
++++ b/support/nsm/rpc.c 2017-08-26 07:41:11.884000000 +0200
+@@ -40,6 +40,7 @@
+
+ #include <time.h>
+ #include <stdbool.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <fcntl.h>