aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libgit2-mtime-0.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libgit2-mtime-0.patch')
-rw-r--r--gnu/packages/patches/libgit2-mtime-0.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/libgit2-mtime-0.patch b/gnu/packages/patches/libgit2-mtime-0.patch
new file mode 100644
index 0000000000..a6fdb50fff
--- /dev/null
+++ b/gnu/packages/patches/libgit2-mtime-0.patch
@@ -0,0 +1,14 @@
+The Clar test framework has a bug whereby it skips the parsing phase
+on files with mtime=0.
+
+Reported upstream at <https://github.com/vmg/clar/pull/78>.
+
+diff --git a/tests/generate.py b/tests/generate.py
+index b639c8f..111ca41 100644
+--- a/tests/generate.py
++++ b/tests/generate.py
+@@ -63,3 +63,3 @@ class Module(object):
+
+- self.mtime = 0
++ self.mtime = None # Guix sets all file mtimes to '0'
+ self.enabled = True