aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ldc-disable-phobos-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ldc-disable-phobos-tests.patch')
-rw-r--r--gnu/packages/patches/ldc-disable-phobos-tests.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/ldc-disable-phobos-tests.patch b/gnu/packages/patches/ldc-disable-phobos-tests.patch
new file mode 100644
index 0000000000..f8a9743d59
--- /dev/null
+++ b/gnu/packages/patches/ldc-disable-phobos-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/std/socket.d b/std/socket.d
+index 111cd17..6d23da9 100644
+--- a/std/socket.d
++++ b/std/socket.d
+@@ -448,7 +448,7 @@ class Protocol
+ // Skip this test on Android because getprotobyname/number are
+ // unimplemented in bionic.
+ version(CRuntime_Bionic) {} else
+-@safe unittest
++@safe version(hasNetwork) unittest
+ {
+ // import std.stdio : writefln;
+ softUnittest({
+@@ -770,7 +770,7 @@ class InternetHost
+ }
+
+ ///
+-@safe unittest
++@safe version(hasNetwork) unittest
+ {
+ InternetHost ih = new InternetHost;
+