aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/isc-dhcp-4.4.1-fixes-for-newer-bind.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/isc-dhcp-4.4.1-fixes-for-newer-bind.patch')
-rw-r--r--gnu/packages/patches/isc-dhcp-4.4.1-fixes-for-newer-bind.patch100
1 files changed, 0 insertions, 100 deletions
diff --git a/gnu/packages/patches/isc-dhcp-4.4.1-fixes-for-newer-bind.patch b/gnu/packages/patches/isc-dhcp-4.4.1-fixes-for-newer-bind.patch
deleted file mode 100644
index 53e681ea31..0000000000
--- a/gnu/packages/patches/isc-dhcp-4.4.1-fixes-for-newer-bind.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-These fixes are needed to adapt isc-dhcp-4.4.1 to build
-successfully after its bundled copy of bind has been updated.
-
-It is derived from the following upstream commits:
-
-commit 8194daabfd590f17825f0c61e9534bee5c99cc86
-Author: Thomas Markwalder <tmark@isc.org>
-Date: Fri Sep 14 13:41:14 2018 -0400
-
- [master] Added includes of new BIND9 compatibility headers, updated util/bind.sh
-
- Merges in rt48072.
-
-commit cc35f84943df44dac2499f3e16e8aaba7d54191d
-Author: Thomas Markwalder <tmark@isc.org>
-Date: Tue Mar 19 08:36:23 2019 -0400
-
- [master] Avoid Bind9 python dependency
-
- merges [#3,!1] Avoid Bind9 python dependency
-
---- a/bind/Makefile.in
-+++ b/bind/Makefile.in
-@@ -23,7 +23,7 @@ exec_prefix = @exec_prefix@
-
- bindconfig = --without-openssl --without-libxml2 --without-libjson \
- --without-gssapi --disable-threads --without-lmdb \
-- --includedir=@includedir@ --libdir=@libdir@ \
-+ --includedir=@includedir@ --libdir=@libdir@ --without-python\
- @BINDLT@ @BINDIOMUX@ @BINDCONFIG@ --enable-full-report
-
- @BIND_ATF_FALSE@cleandirs = ./lib ./include
-diff --git a/includes/omapip/isclib.h b/includes/omapip/isclib.h
-index 75a87ff6..538b927f 100644
---- a/includes/omapip/isclib.h
-+++ b/includes/omapip/isclib.h
-@@ -48,6 +48,9 @@
- #include <string.h>
- #include <netdb.h>
-
-+#include <isc/boolean.h>
-+#include <isc/int.h>
-+
- #include <isc/buffer.h>
- #include <isc/lex.h>
- #include <isc/lib.h>
-diff --git a/includes/omapip/result.h b/includes/omapip/result.h
-index 91243e1b..860298f6 100644
---- a/includes/omapip/result.h
-+++ b/includes/omapip/result.h
-@@ -26,6 +26,7 @@
- #ifndef DHCP_RESULT_H
- #define DHCP_RESULT_H 1
-
-+#include <isc/boolean.h>
- #include <isc/lang.h>
- #include <isc/resultclass.h>
- #include <isc/types.h>
-diff --git a/server/dhcpv6.c b/server/dhcpv6.c
-index a7110f98..cde4f617 100644
---- a/server/dhcpv6.c
-+++ b/server/dhcpv6.c
-@@ -1034,7 +1034,8 @@ void check_pool6_threshold(struct reply_state *reply,
- shared_name,
- inet_ntop(AF_INET6, &lease->addr,
- tmp_addr, sizeof(tmp_addr)),
-- used, count);
-+ (long long unsigned)(used),
-+ (long long unsigned)(count));
- }
- return;
- }
-@@ -1066,7 +1067,8 @@ void check_pool6_threshold(struct reply_state *reply,
- "address: %s; high threshold %d%% %llu/%llu.",
- shared_name,
- inet_ntop(AF_INET6, &lease->addr, tmp_addr, sizeof(tmp_addr)),
-- poolhigh, used, count);
-+ poolhigh, (long long unsigned)(used),
-+ (long long unsigned)(count));
-
- /* handle the low threshold now, if we don't
- * have one we default to 0. */
-@@ -1436,12 +1438,15 @@ pick_v6_address(struct reply_state *reply)
- log_debug("Unable to pick client address: "
- "no addresses available - shared network %s: "
- " 2^64-1 < total, %llu active, %llu abandoned",
-- shared_name, active - abandoned, abandoned);
-+ shared_name, (long long unsigned)(active - abandoned),
-+ (long long unsigned)(abandoned));
- } else {
- log_debug("Unable to pick client address: "
- "no addresses available - shared network %s: "
- "%llu total, %llu active, %llu abandoned",
-- shared_name, total, active - abandoned, abandoned);
-+ shared_name, (long long unsigned)(total),
-+ (long long unsigned)(active - abandoned),
-+ (long long unsigned)(abandoned));
- }
-
- return ISC_R_NORESOURCES;