aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/hash-extender-test-suite.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/hash-extender-test-suite.patch')
-rw-r--r--gnu/packages/patches/hash-extender-test-suite.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/hash-extender-test-suite.patch b/gnu/packages/patches/hash-extender-test-suite.patch
new file mode 100644
index 0000000000..59de52dad4
--- /dev/null
+++ b/gnu/packages/patches/hash-extender-test-suite.patch
@@ -0,0 +1,13 @@
+Make the test suite exit with a non-zero exit code if some tests failed.
+Pull request pending upstream: https://github.com/iagox86/hash_extender/pull/13
+--- a/test.c
++++ b/test.c
+@@ -79,5 +79,9 @@ void test_report(void)
+ printf("TESTS PASSED: %d / %d [%2.4f%%]\n", tests_passed, tests_run, 100 * (float)tests_passed / tests_run);
+ printf("--------------------------------------------------------------------------------\n");
+ }
++
++ if (tests_passed != tests_run) {
++ exit(1);
++ }
+ }