aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/handbrake-opt-in-nvenc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/handbrake-opt-in-nvenc.patch')
-rw-r--r--gnu/packages/patches/handbrake-opt-in-nvenc.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/handbrake-opt-in-nvenc.patch b/gnu/packages/patches/handbrake-opt-in-nvenc.patch
new file mode 100644
index 0000000000..2b34aaa427
--- /dev/null
+++ b/gnu/packages/patches/handbrake-opt-in-nvenc.patch
@@ -0,0 +1,14 @@
+Require opt-in for NVEnc support. Otherwise the default is true with no way
+to disable it.
+
+--- HandBrake-1.2.0/make/configure.py.orig 1969-12-31 18:00:00.000000000 -0600
++++ HandBrake-1.2.0/make/configure.py 2019-01-22 23:22:46.186959060 -0600
+@@ -1320,7 +1320,7 @@
+ grp.add_option( '--disable-ffmpeg-aac', dest="enable_ffmpeg_aac", action='store_false' )
+
+ h = IfHost( 'enable Nvidia NVEnc video encoder', '*-*-*', none=optparse.SUPPRESS_HELP ).value
+- grp.add_option( '--enable-nvenc', dest="enable_nvenc", default=not (host.match( '*-*-darwin*' ) or host.match( '*-*-freebsd*' )), action='store_true', help=h )
++ grp.add_option( '--enable-nvenc', dest="enable_nvenc", default=False, action='store_true', help=h )
+
+
+ cli.add_option_group( grp )