aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/flex-bison-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/flex-bison-tests.patch')
-rw-r--r--gnu/packages/patches/flex-bison-tests.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/flex-bison-tests.patch b/gnu/packages/patches/flex-bison-tests.patch
new file mode 100644
index 0000000000..0f372f83bf
--- /dev/null
+++ b/gnu/packages/patches/flex-bison-tests.patch
@@ -0,0 +1,24 @@
+The `test-bison-yyl{loc,val}' tests fail with "conflicting types for
+'testparse'" because `YYPARSE_PARAM' is undefined; work around that.
+
+--- flex-2.5.37/tests/test-bison-yylloc/main.c 2012-11-22 18:17:01.000000000 +0100
++++ flex-2.5.37/tests/test-bison-yylloc/main.c 2012-11-22 18:17:07.000000000 +0100
+@@ -21,6 +21,7 @@
+ * PURPOSE.
+ */
+
++#define YYPARSE_PARAM scanner
+ #include "parser.h"
+ #include "scanner.h"
+
+
+--- flex-2.5.37/tests/test-bison-yylval/main.c 2012-11-22 18:17:42.000000000 +0100
++++ flex-2.5.37/tests/test-bison-yylval/main.c 2012-11-22 18:17:49.000000000 +0100
+@@ -21,6 +21,7 @@
+ * PURPOSE.
+ */
+
++#define YYPARSE_PARAM scanner
+ #include "parser.h"
+ #include "scanner.h"
+