aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ceph-volume-respect-PATH.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ceph-volume-respect-PATH.patch')
-rw-r--r--gnu/packages/patches/ceph-volume-respect-PATH.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/ceph-volume-respect-PATH.patch b/gnu/packages/patches/ceph-volume-respect-PATH.patch
new file mode 100644
index 0000000000..08a9a15ddd
--- /dev/null
+++ b/gnu/packages/patches/ceph-volume-respect-PATH.patch
@@ -0,0 +1,22 @@
+Look for required tools in $PATH instead of just a handful locations.
+
+diff --git a/src/ceph-volume/ceph_volume/util/system.py b/src/ceph-volume/ceph_volume/util/system.py
+index b637f023a4..14516e1c65 100644
+--- a/src/ceph-volume/ceph_volume/util/system.py
++++ b/src/ceph-volume/ceph_volume/util/system.py
+@@ -33,14 +33,7 @@ def generate_uuid():
+
+ def which(executable):
+ """find the location of an executable"""
+- locations = (
+- '/usr/local/bin',
+- '/bin',
+- '/usr/bin',
+- '/usr/local/sbin',
+- '/usr/sbin',
+- '/sbin',
+- )
++ locations = os.getenv('PATH').split(':')
+
+ for location in locations:
+ executable_path = os.path.join(location, executable)