aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch')
-rw-r--r--gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch b/gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch
deleted file mode 100644
index f9427cbe61..0000000000
--- a/gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From: Antonio Larrosa <larrosa@kde.org>
-Date: Mon, 6 Mar 2017 12:51:22 +0100
-Subject: Always check the number of coefficients
-
-When building the library with NDEBUG, asserts are eliminated
-so it's better to always check that the number of coefficients
-is inside the array range.
-
-This fixes the 00191-audiofile-indexoob issue in #41
----
- libaudiofile/WAVE.cpp | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/libaudiofile/WAVE.cpp b/libaudiofile/WAVE.cpp
-index 9dd8511..0fc48e8 100644
---- a/libaudiofile/WAVE.cpp
-+++ b/libaudiofile/WAVE.cpp
-@@ -281,6 +281,12 @@ status WAVEFile::parseFormat(const Tag &id, uint32_t size)
-
- /* numCoefficients should be at least 7. */
- assert(numCoefficients >= 7 && numCoefficients <= 255);
-+ if (numCoefficients < 7 || numCoefficients > 255)
-+ {
-+ _af_error(AF_BAD_HEADER,
-+ "Bad number of coefficients");
-+ return AF_FAIL;
-+ }
-
- m_msadpcmNumCoefficients = numCoefficients;
-