aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audacity-add-include.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/audacity-add-include.patch')
-rw-r--r--gnu/packages/patches/audacity-add-include.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/audacity-add-include.patch b/gnu/packages/patches/audacity-add-include.patch
new file mode 100644
index 0000000000..a7f27918e7
--- /dev/null
+++ b/gnu/packages/patches/audacity-add-include.patch
@@ -0,0 +1,15 @@
+Without <sys/time.h>, gettimeofday is undefined.
+
+diff --git a/src/AudioIO.cpp b/src/AudioIO.cpp
+index 0187e3962..e15d55f4c 100644
+--- a/src/AudioIO.cpp
++++ b/src/AudioIO.cpp
+@@ -479,6 +479,8 @@ time warp info and AudioIOListener and whether the playback is looped.
+ #include "../lib-src/portmidi/porttime/porttime.h"
+ #include "../lib-src/header-substitutes/allegro.h"
+
++#include <sys/time.h>
++
+ #define MIDI_SLEEP 10 /* milliseconds */
+ // how long do we think the thread that fills MIDI buffers,
+ // if it is separate from the portaudio thread,