aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index f6a399aa2f..632534fb3c 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -65,10 +65,16 @@
To do this Bandit processes each file, builds an AST from it, and runs
appropriate plugins against the AST nodes. Once Bandit has finished scanning
all the files it generates a report.")
+ (properties `((python2-variant . ,(delay python2-bandit))))
(license asl2.0)))
(define-public python2-bandit
- (package-with-python2 python-bandit))
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-bandit)))
+ (arguments
+ `(#:python ,python-2
+ ;; FIXME: 'subunit.run discover: error: no such option: --list'
+ #:tests? #f))))
(define-public python-debtcollector
(package