aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index b355665da0..7abe9ab6f0 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -57,7 +57,7 @@
(define-public openldap
(package
(name "openldap")
- (version "2.4.46")
+ (version "2.4.47")
(source (origin
(method url-fetch)
@@ -74,7 +74,7 @@
"openldap-release/openldap-" version ".tgz")))
(sha256
(base32
- "0bab1km8f2nan1x0zgwliknbxg0zlf2pafxrr867kblrdfwdr44s"))))
+ "02sj0p1pq12hqq29b22m3f5zs2rykgvc0q3wlynxjcsjhrvmhk7m"))))
(build-system gnu-build-system)
(inputs `(("bdb" ,bdb-5.3)
("cyrus-sasl" ,cyrus-sasl)
@@ -211,7 +211,11 @@ servers from Python programs.")
(arguments
`(#:modules ((srfi srfi-1)
(guix build gnu-build-system)
+ ((guix build python-build-system)
+ #:select (python-version))
(guix build utils))
+ #:imported-modules ((guix build python-build-system)
+ ,@%gnu-build-system-modules)
#:configure-flags
(list (string-append "--with-db="
(assoc-ref %build-inputs "bdb"))
@@ -263,16 +267,9 @@ servers from Python programs.")
(add-after 'unpack 'fix-install-location-of-python-tools
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (get-python-version
- ;; FIXME: copied from python-build-system
- (lambda (python)
- (let* ((version (last (string-split python #\-)))
- (components (string-split version #\.))
- (major+minor (take components 2)))
- (string-join major+minor "."))))
(pythondir (string-append
out "/lib/python"
- (get-python-version (assoc-ref inputs "python"))
+ (python-version (assoc-ref inputs "python"))
"/site-packages/")))
;; Install directory must be on PYTHONPATH.
(setenv "PYTHONPATH"