aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9069b320e9..7a9e8d4f89 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4462,6 +4462,22 @@ writing to these structures, and they are accessed via the Bigarray module.")
(define ocaml-cstruct-unix ocaml-cstruct)
(define ocaml-cstruct-sexp ocaml-cstruct)
+(define-public ocaml-ppx-cstruct
+ (package
+ (inherit ocaml-cstruct)
+ (name "ocaml-ppx-cstruct")
+ (properties `((upstream-name . "ppx_cstruct")))
+ (arguments
+ '(#:package "ppx_cstruct"
+ ;; TODO doesn't find test deps for some reason?
+ ;; I have no clue why.
+ #:tests? #f))
+ (propagated-inputs (modify-inputs (package-propagated-inputs ocaml-cstruct)
+ (append ocaml-cstruct ocaml-ppxlib ocaml-sexplib)))
+ (native-inputs (modify-inputs (package-propagated-inputs ocaml-cstruct)
+ (append ocaml-cstruct-sexp ocaml-findlib
+ ocaml-ppx-sexp-conv)))))
+
(define-public ocaml-hex
(package
(name "ocaml-hex")