aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 419b6d7321..9429778776 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -108,8 +109,11 @@ computers over a network.")
"0fn12i4kzsi0zkr4qp3dp9bycmirnfapajqvdfx02zhr4hanj0kv"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--with-privsep-user=ntpd"
- "--localstatedir=/var")
+ '(#:configure-flags `( "--with-privsep-user=ntpd"
+ "--localstatedir=/var"
+ ,(string-append "--with-cacert="
+ (assoc-ref %build-inputs "libressl")
+ "/etc/ssl/cert.pem"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'modify-install-locations
@@ -165,7 +169,7 @@ minimalist than ntpd.")
;; received from servers.
(setenv "COMPILE_DATE" (number->string 1530144000))
(invoke "sh" "autogen.sh"))))))
- (inputs `(("openssl" ,openssl)
+ (inputs `(("openssl" ,openssl-1.0)
("libevent" ,libevent)))
(native-inputs `(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)