aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/nim.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/nim.scm')
-rw-r--r--gnu/packages/nim.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
index 560f10e4ad..5694eae63b 100644
--- a/gnu/packages/nim.scm
+++ b/gnu/packages/nim.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,7 @@
(define-public nim
(package
(name "nim")
- (version "0.17.0")
+ (version "0.17.2")
(source
(origin
(method url-fetch)
@@ -34,13 +35,13 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "16vsmk4rqnkg9lc9h9jk62ps0x778cdqg6qrs3k6fv2g73cqvq9n"))))
+ "1gc2xk3ygmz9y4pm75pligssgw995a7gvnfpy445fjpw4d81pzxa"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests.
#:phases
(modify-phases %standard-phases
- (delete 'configure)
+ (delete 'configure) ; no configure script
(add-after 'unpack 'patch-installer
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -56,11 +57,13 @@
#t))
(replace 'build
(lambda _
- (zero? (system* "sh" "build.sh"))))
+ (invoke "sh" "build.sh")
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "./install.sh" out))))))))
+ (invoke "./install.sh" out)
+ #t))))))
(home-page "https://nim-lang.org")
(synopsis "Statically-typed, imperative programming language")
(description "Nim (formerly known as Nimrod) is a statically-typed,