aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm75
1 files changed, 54 insertions, 21 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ab881845ed..fc6c29855d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -13,7 +13,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2017, 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 nee <nee.git@hidamari.blue>
;;; Copyright © 2018 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -32,6 +32,7 @@
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2019 Riku Viitanen <riku.viitanen0@gmail.com>
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1838,7 +1839,7 @@ users to select LV2 plugins and run them with jalv.")
(define-public synthv1
(package
(name "synthv1")
- (version "0.9.18")
+ (version "0.9.19")
(source (origin
(method url-fetch)
(uri
@@ -1846,7 +1847,7 @@ users to select LV2 plugins and run them with jalv.")
"/synthv1-" version ".tar.gz"))
(sha256
(base32
- "1sggiaswcdpyxnnbg583ldg0m92fiys6nc5qdiqli7450w416a6c"))))
+ "17sizhav01mn07gi812n8wqdcr85290zqg609s18cww2b95dy6mn"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ; there are no tests
@@ -1870,7 +1871,7 @@ oscillators and stereo effects.")
(define-public drumkv1
(package
(name "drumkv1")
- (version "0.9.18")
+ (version "0.9.19")
(source (origin
(method url-fetch)
(uri
@@ -1878,7 +1879,7 @@ oscillators and stereo effects.")
"/drumkv1-" version ".tar.gz"))
(sha256
(base32
- "1bzkaz7sqx1pvirja8zm7i2ckzl5ad6xspr4840389ik3l8qpnr5"))))
+ "0w9frc634yg2m0yc84szdf6x7l4f19pcviqpg065a1kdixf98qrf"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ; there are no tests
@@ -1903,7 +1904,7 @@ effects.")
(define-public samplv1
(package
(name "samplv1")
- (version "0.9.18")
+ (version "0.9.19")
(source (origin
(method url-fetch)
(uri
@@ -1911,7 +1912,7 @@ effects.")
"/samplv1-" version ".tar.gz"))
(sha256
(base32
- "13p5aj1513fwhzi9s4i1a5dbvzmbx9867zb0ddb9s9nbwks4ry3q"))))
+ "1fwvk83sfvp1k6qyqv1a7a1l8sbm6azcldaiiqa3ls1vhl4m5wv4"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ; there are no tests
@@ -1936,7 +1937,7 @@ effects.")
(define-public padthv1
(package
(name "padthv1")
- (version "0.9.18")
+ (version "0.9.19")
(source (origin
(method url-fetch)
(uri
@@ -1944,7 +1945,7 @@ effects.")
"/padthv1-" version ".tar.gz"))
(sha256
(base32
- "1karrprb3ijrbiwpr43rl3nxnzc33lnmwrd1832psgr3flnr9fp5"))))
+ "06fkrc4xxzr3sa3c76lnkcm4q9k0xl5993bn60la0ja4sz2kp6r7"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ; there are no tests
@@ -2512,14 +2513,14 @@ browser.")
(define-public drumstick
(package
(name "drumstick")
- (version "1.1.3")
+ (version "2.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/drumstick/"
version "/drumstick-" version ".tar.bz2"))
(sha256
(base32
- "1n9wvg79yvkygrkc8xd8pgrd3d7hqmr7gh24dccf0px23lla9b3m"))))
+ "088j0w3kr9i4lh78y0js0q8adlfzkr89xq2dxc8y3bafsgihax1x"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no test target
@@ -2538,12 +2539,14 @@ browser.")
(inputs
`(("qtbase" ,qtbase)
("qtsvg" ,qtsvg)
+ ("qttools" ,qttools)
("alsa-lib" ,alsa-lib)))
(native-inputs
`(("pkg-config" ,pkg-config)
("libxslt" ,libxslt) ; for xsltproc
("docbook-xsl" ,docbook-xsl)
- ("doxygen" ,doxygen)))
+ ("doxygen" ,doxygen)
+ ("graphviz" ,graphviz))) ; for dot
(home-page "http://drumstick.sourceforge.net/")
(synopsis "C++ MIDI library")
(description
@@ -2558,14 +2561,14 @@ backends, including ALSA, OSS, Network and FluidSynth.")
(define-public vmpk
(package
(name "vmpk")
- (version "0.7.2")
+ (version "0.8.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/vmpk/vmpk/"
version "/vmpk-" version ".tar.bz2"))
(sha256
(base32
- "1i3hnvdgz46n4k5v0q4jhgh7nkh0s390ix4nqr69z0q3026yp0p6"))))
+ "0wn45c4sbvan7schq93zmsgg5fcf144mbbawxn5kq699vrbc3473"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no test target
@@ -2650,7 +2653,7 @@ capabilities, custom envelopes, effects, etc.")
(define-public yoshimi
(package
(name "yoshimi")
- (version "1.7.3")
+ (version "1.7.4")
(source
(origin
(method url-fetch)
@@ -2658,7 +2661,7 @@ capabilities, custom envelopes, effects, etc.")
(version-major+minor version)
"/yoshimi-" version ".tar.bz2"))
(sha256
- (base32 "1ixb2kqmfgm2lfjaj6z3h03c840hcfmca4h6pjnc4aln2mzm7fcw"))))
+ (base32 "0lxfqj4p4njww3n0wa6yfj38zfls16y3wszd47gvc5asmqyg5vjd"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -2910,14 +2913,14 @@ from the command line.")
(define-public qtractor
(package
(name "qtractor")
- (version "0.9.18")
+ (version "0.9.19")
(source (origin
(method url-fetch)
(uri (string-append "https://downloads.sourceforge.net/qtractor/"
"qtractor-" version ".tar.gz"))
(sha256
(base32
- "121vmygdzp37p6f93f8dbbg2m2r55j7amyiapzkqgypgn4vfdbwr"))))
+ "0gdr1hvda56vmv4998z9xcqsp7da6lplj00f217x9g2i2snyvkzp"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ; no "check" target
@@ -4398,6 +4401,36 @@ melodies and beats and for mixing and arranging songs. LMMS includes instrument
audio samples and various soft sythesizers. It can receive input from a MIDI keyboard.")
(license license:gpl2+)))
+(define-public liquidsfz
+ (package
+ (name "liquidsfz")
+ (version "0.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://space.twc.de/~stefan/liquidsfz/"
+ "liquidsfz-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "011m839vjb8gmiv1vzc0d7xz2q2jiwk4v0j9paqyx3lm61czvy93"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--enable-shared")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ;; Fails with default gcc (#include <filesystem> not found).
+ ("gcc" ,gcc-9)))
+ (inputs
+ `(("jack" ,jack-2)
+ ("lv2" ,lv2)
+ ("readline" ,readline)
+ ("libsndfile" ,libsndfile)))
+ (home-page "https://github.com/swesterfeld/liquidsfz")
+ (synopsis "Sampler library")
+ (description "The main goal of liquidsfz is to provide an SFZ sampler
+implementation library that is easy to integrate into other projects. A
+standalone JACK client and an LV2 plugin is also available.")
+ (license license:lgpl2.1+)))
+
(define-public musescore
(package
(name "musescore")
@@ -5782,7 +5815,7 @@ and as an LV2 plugin.")
;; distros to make necessary changes to integrate the software into the
;; distribution.
(name "zrythm")
- (version "1.0.0-alpha.3.0.1")
+ (version "1.0.0-alpha.6.0.1")
(source
(origin
(method url-fetch)
@@ -5790,7 +5823,7 @@ and as an LV2 plugin.")
version ".tar.xz"))
(sha256
(base32
- "06025367x08y4g9grhcn35bk1dsrpgm04c8l8j50i3p49dl3s1n0"))))
+ "1zfky3yj0k0rmbxighlk9sp4fsgw8rj7viv44yv626kldfvc04ab"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t