aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b59f258ae5..2314fdc442 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2704,6 +2704,12 @@ Songs can be searched by artist, name or even by a part of the song text.")
(lambda _
(setenv "HOME" (string-append (getcwd) "/tmp"))
#t))
+ (add-after 'unpack 'make-python3.7-compatible
+ (lambda _
+ ;; See <https://github.com/beetbox/beets/issues/2978>.
+ (substitute* "beets/autotag/hooks.py"
+ (("re\\._pattern_type") "re.Pattern"))
+ #t))
(replace 'check
(lambda _
(invoke "nosetests" "-v"))))))