aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm133
1 files changed, 71 insertions, 62 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2850d309ca..6f42160f77 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -109,14 +109,14 @@
(define-public aria-maestosa
(package
(name "aria-maestosa")
- (version "1.4.11")
+ (version "1.4.13")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/ariamaestosa/ariamaestosa/"
version "/AriaSrc-" version ".tar.bz2"))
(sha256
(base32
- "0gf9z96z83jiabxhpl856j15vl9flfgs6x1r0r6hc7g2xvwag0vy"))))
+ "1cs3z6frx2ch7rm5ammx9p0rxcjrbj1vq14hvcbimpaw39rdsn3d"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no tests
@@ -479,7 +479,7 @@ enable professional yet simple and intuitive pattern-based drum programming.")
("emacs" ,emacs-no-x)))
;; Extempore refuses to build on architectures other than x86_64
(supported-systems '("x86_64-linux"))
- (home-page "http://benswift.me/extempore-docs/index.html")
+ (home-page "http://digego.github.io/extempore/")
(synopsis "Programming environment for live coding of multimedia")
(description
"Extempore is a programming language and runtime environment designed
@@ -585,7 +585,7 @@ interface. It is implemented as a frontend to @code{klick}.")
(define-public lilypond
(package
(name "lilypond")
- (version "2.19.51")
+ (version "2.19.58")
(source (origin
(method url-fetch)
(uri (string-append
@@ -594,7 +594,7 @@ interface. It is implemented as a frontend to @code{klick}.")
name "-" version ".tar.gz"))
(sha256
(base32
- "1b4jvc0fixbnp8x457fzk5wgb4zd03npwwivp60kc27fmv63w5l1"))))
+ "0wjapb3if6qqdmr57z20hidx7czhl023cjimr01i8yf7k41fakh7"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; out-test/collated-files.html fails
@@ -670,8 +670,8 @@ Guile.")
(define-public non-sequencer
;; The latest tagged release is three years old and uses a custom build
;; system, so we take the last commit.
- (let ((commit "a22f33f486a5c6f75b60e36f66504c036c0f6f8c")
- (revision "2"))
+ (let ((commit "10c31e57291b6e42be53371567a722b62b32d220")
+ (revision "3"))
(package
(name "non-sequencer")
(version (string-append "1.9.5-" revision "." (string-take commit 7)))
@@ -682,7 +682,7 @@ Guile.")
(commit commit)))
(sha256
(base32
- "09q5x8i4f8mqnl8w6xnsq5zriy4bzdl4x2vq9n34a433rfrk84bg"))
+ "080rha4ffp7qycyg1mqcf4vj0s7z8qfvz6bxm0w29xgg2kkmb3fx"))
(file-name (string-append name "-" version "-checkout"))))
(build-system waf-build-system)
(arguments
@@ -983,7 +983,7 @@ users to select LV2 plugins and run them with jalv.")
(define-public synthv1
(package
(name "synthv1")
- (version "0.8.0")
+ (version "0.8.1")
(source (origin
(method url-fetch)
(uri
@@ -991,7 +991,7 @@ users to select LV2 plugins and run them with jalv.")
"/synthv1-" version ".tar.gz"))
(sha256
(base32
- "155pfyhr6d35ciw95pbxlqy7751cmij8j5d849rvblqbjzyzb5qx"))))
+ "0rzkr8mgy28j5kg56qqrdm05ml2wlm651yk27c2mn5ql7v92gdx3"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; There are no tests.
@@ -1014,7 +1014,7 @@ oscillators and stereo effects.")
(define-public drumkv1
(package
(name "drumkv1")
- (version "0.8.0")
+ (version "0.8.1")
(source (origin
(method url-fetch)
(uri
@@ -1022,7 +1022,7 @@ oscillators and stereo effects.")
"/drumkv1-" version ".tar.gz"))
(sha256
(base32
- "1n2kd468kn71yp2asmamprvblmdlvh0zd8lsh3598dwi4b7aa3ga"))))
+ "0l6kjb1q9vslwy56836a0c65mf8z8ycam5vzz3k4qvd8g74bs1zq"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; There are no tests.
@@ -1048,7 +1048,7 @@ effects.")
(define-public samplv1
(package
(name "samplv1")
- (version "0.8.0")
+ (version "0.8.1")
(source (origin
(method url-fetch)
(uri
@@ -1056,7 +1056,7 @@ effects.")
"/samplv1-" version ".tar.gz"))
(sha256
(base32
- "0j3hkmd9q0bw9b7nk9cssqywlrishkd1n790a9vq6gh3pdc5sf3r"))))
+ "15rp9d1jbb56idyrnn9cqi1i7a70z1a1qdyz7ryn0bla0ghjnich"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; There are no tests.
@@ -1082,7 +1082,7 @@ effects.")
(define-public amsynth
(package
(name "amsynth")
- (version "1.6.4")
+ (version "1.7.1")
(source
(origin
(method url-fetch)
@@ -1091,7 +1091,7 @@ effects.")
"/amsynth-" version ".tar.bz2"))
(sha256
(base32
- "07dp9dl38g9krjqxxh89l2z42z08yzrl57cx95b1l67xnxwjp5k3"))))
+ "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1105,11 +1105,13 @@ effects.")
`(("alsa-lib" ,alsa-lib)
("jack" ,jack-1)
("lv2" ,lv2)
+ ("lash" ,lash)
("libsndfile" ,libsndfile)
("gtk+" ,gtk+-2)
("gtkmm" ,gtkmm-2)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
(home-page "http://amsynth.github.io")
(synopsis "Analog modeling synthesizer")
(description
@@ -1125,7 +1127,7 @@ reverb effects.")
(define-public setbfree
(package
(name "setbfree")
- (version "0.8.1")
+ (version "0.8.4")
(source (origin
(method url-fetch)
(uri
@@ -1134,7 +1136,7 @@ reverb effects.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0hj0rqk5yd4fzs7bwy6a6nhqgrmcggkjcr4il76rxy92r7nwabf3"))))
+ "1g4s1920kb2q5gpp82l2vxia29qa8g8zvdjgrca8ypynvxpzn65f"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
@@ -1275,7 +1277,7 @@ is subjective.")
(define-public tuxguitar
(package
(name "tuxguitar")
- (version "1.3.2")
+ (version "1.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1283,11 +1285,14 @@ is subjective.")
version "/tuxguitar-" version "-src.tar.gz"))
(sha256
(base32
- "0ldml31zvywid1w28mfd65ramyiics55fdl0ch846vm7j7nwv58j"))
+ "041275vwfr82kass7wiq9g2y82w9qrbzfinzcvfij2f2q45njwmc"))
(modules '((guix build utils)))
(snippet
- ;; Delete pre-built classes
- '(delete-file-recursively "TuxGuitar-android/bin"))))
+ '(begin
+ ;; Delete pre-built classes
+ (delete-file-recursively "TuxGuitar-android-gdrive/bin")
+ (delete-file-recursively "TuxGuitar-android-gdrive-gdaa/bin")
+ #t))))
(build-system ant-build-system)
(arguments
`(#:build-target "build"
@@ -1296,23 +1301,31 @@ is subjective.")
(modify-phases %standard-phases
(add-after 'unpack 'enter-dir
(lambda _ (chdir "TuxGuitar-lib") #t))
- (add-after 'build 'build-editor-utils
+ (add-after 'build 'build-libraries
(lambda* (#:key inputs outputs #:allow-other-keys)
- (chdir "..")
- (let ((cwd (getcwd)))
- (setenv "CLASSPATH"
- (string-append
- cwd "/TuxGuitar-lib/tuxguitar-lib.jar" ":"
- cwd "/TuxGuitar-editor-utils/build/jar/tuxguitar-editor-utils.jar" ":"
- (getenv "CLASSPATH"))))
- (chdir "TuxGuitar-editor-utils")
- ;; Generate default build.xml
- ((@@ (guix build ant-build-system) default-build.xml)
- "tuxguitar-editor-utils.jar"
- (string-append (assoc-ref outputs "out")
- "/share/java"))
- ((assoc-ref %standard-phases 'build))))
- (add-after 'build-editor-utils 'build-application
+ (let* ((initial-classpath (getenv "CLASSPATH"))
+ (build-dir (lambda (dir)
+ (chdir "..")
+ (setenv "CLASSPATH"
+ (string-join (cons initial-classpath
+ (find-files (getcwd) "\\.jar$"))
+ ":"))
+ (chdir dir)
+ (if (file-exists? "build.xml")
+ ((assoc-ref %standard-phases 'build)
+ #:build-target "build")
+ (begin
+ ;; Generate default build.xml
+ ((@@ (guix build ant-build-system) default-build.xml)
+ (string-append (string-downcase dir) ".jar")
+ (string-append (assoc-ref outputs "out")
+ "/share/java"))
+ ((assoc-ref %standard-phases 'build)))))))
+ (map build-dir '("TuxGuitar-editor-utils"
+ "TuxGuitar-ui-toolkit"
+ "TuxGuitar-ui-toolkit-swt"
+ "TuxGuitar-awt-graphics")))))
+ (add-after 'build-libraries 'build-application
(lambda _
(chdir "../TuxGuitar")
((assoc-ref %standard-phases 'build)
@@ -1329,10 +1342,10 @@ is subjective.")
(for-each (lambda (file)
(install-file file lib))
(find-files ".." "\\.jar$"))
+
;; install all resources
- (for-each (lambda (file)
- (install-file file share))
- (find-files "share" ".*"))
+ (copy-recursively "share" share)
+
;; create wrapper
(call-with-output-file (string-append bin "/tuxguitar")
(lambda (port)
@@ -1353,7 +1366,7 @@ is subjective.")
#t))))))
(inputs
`(("java-swt" ,java-swt)))
- (home-page "http://tuxguitar.com.ar")
+ (home-page "http://tuxguitar.pw")
(synopsis "Multitrack tablature editor and player")
(description
"TuxGuitar is a guitar tablature editor with player support through midi.
@@ -1367,33 +1380,29 @@ export.")
(define-public pd
(package
(name "pd")
- (version "0.45.4")
+ (version "0.47-1")
(source (origin
(method url-fetch)
(uri
- (string-append "mirror://sourceforge/pure-data/pure-data/"
- version "/pd-" (version-major+minor version)
- "-" (last (string-split version #\.))
- ".src.tar.gz"))
+ (string-append "http://msp.ucsd.edu/Software/pd-"
+ version ".src.tar.gz"))
(sha256
(base32
- "1ls2ap5yi2zxvmr247621g4jx0hhfds4j5704a050bn2n3l0va2p"))))
+ "0k5s949kqd7yw97h3m8z81bjz32bis9m4ih8df1z0ymipnafca67"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'fix-wish-path
- (lambda _
- (substitute* "src/s_inter.c"
- ((" wish ") (string-append " " (which "wish8.6") " ")))
- (substitute* "tcl/pd-gui.tcl"
- (("exec wish ") (string-append "exec " (which "wish8.6") " ")))
- #t))
- (add-after
- 'unpack 'autoconf
- (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
+ (add-before 'configure 'fix-wish-path
+ (lambda _
+ (substitute* "src/s_inter.c"
+ ((" wish ") (string-append " " (which "wish8.6") " ")))
+ (substitute* "tcl/pd-gui.tcl"
+ (("exec wish ") (string-append "exec " (which "wish8.6") " ")))
+ #t))
+ (add-after 'unpack 'autoconf
+ (lambda _ (zero? (system* "bash" "./autogen.sh")))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -1630,7 +1639,7 @@ capabilities, custom envelopes, effects, etc.")
(define-public yoshimi
(package
(name "yoshimi")
- (version "1.5.0")
+ (version "1.5.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/yoshimi/"
@@ -1638,7 +1647,7 @@ capabilities, custom envelopes, effects, etc.")
"/yoshimi-" version ".tar.bz2"))
(sha256
(base32
- "10s1i18xlmvqfrnr0zn2mj2b28i7p62dlqzzzkmpaapqj1gsgpz5"))))
+ "09kmq5bwgwwpa5z2mm1pxhnqcryd0cm5ixlafb3g6d3aspja2mkn"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are no tests