aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a26c4fc250..49f784f529 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1881,7 +1881,7 @@ export.")
(define-public pd
(package
(name "pd")
- (version "0.50-2")
+ (version "0.51-0")
(source (origin
(method url-fetch)
(uri
@@ -1889,23 +1889,25 @@ export.")
version ".src.tar.gz"))
(sha256
(base32
- "0dz6r6jy0zfs1xy1xspnrxxks8kddi9c7pxz4vpg2ygwv83ghpg5"))))
+ "0qzv4hjf4h7xx00ihnbl43pxa0fia9qkc8nwgzhqrs12jiljz6ps"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no "check" target
- #:configure-flags
- (list
- "--enable-jack"
- (string-append "--with-wish=" (string-append
- (assoc-ref %build-inputs "tk")
- "/bin/wish8.6")))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'fix-with-path
- (lambda _
- (substitute* "tcl/pd-gui.tcl"
- (("exec wish ") (string-append "exec " (which "wish8.6") " ")))
- #t)))))
+ (let ((wish (string-append "wish" (version-major+minor
+ (package-version tk)))))
+ `(#:tests? #f ; no "check" target
+ #:configure-flags
+ (list
+ "--enable-jack"
+ (string-append "--with-wish=" (string-append
+ (assoc-ref %build-inputs "tk")
+ "/bin/" ,wish)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-with-path
+ (lambda _
+ (substitute* "tcl/pd-gui.tcl"
+ (("exec wish ") (string-append "exec " (which ,wish) " ")))
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -1916,7 +1918,7 @@ export.")
`(("tk" ,tk)
("alsa-lib" ,alsa-lib)
("jack" ,jack-1)))
- (home-page "http://puredata.info")
+ (home-page "https://puredata.info")
(synopsis "Visual programming language for artistic performances")
(description
"Pure Data (aka Pd) is a visual programming language. Pd enables
@@ -3691,7 +3693,7 @@ plugins, a switch trigger, a toggle switch, and a peakmeter.")
("lv2" ,lv2)
("lilv" ,lilv)
("raul" ,raul-devel)
- ("ganv" ,ganv-devel)
+ ("ganv" ,ganv)
("suil" ,suil)
("serd" ,serd)
("sord" ,sord)