aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5ff7389a02..d9bc2922c5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3221,8 +3221,7 @@ ASCII text files using Gmsh's own scripting language.")
((@@ (guix build python-build-system) call-setuppy)
"build_ext"
(list (string-append "--sip-dir="
- (assoc-ref inputs "python-pyqt")
- "/share/sip"))
+ (search-input-directory inputs "share/sip")))
#t)))
;; Ensure that icons are found at runtime.
(add-after 'install 'wrap-executable
@@ -3240,7 +3239,7 @@ ASCII text files using Gmsh's own scripting language.")
(list ghostscript ;optional, for EPS/PS output
python-dbus
python-h5py ;optional, for HDF5 data
- python-pyqt
+ python-pyqt-without-qtwebkit
qtbase-5
qtsvg-5))
(propagated-inputs