aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 12 insertions, 18 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7866bcc6eb..eff1480e62 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -104,6 +104,7 @@
#:use-module (gnu packages less)
#:use-module (gnu packages lisp)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages llvm)
#:use-module (gnu packages logging)
#:use-module (gnu packages lua)
#:use-module (gnu packages gnome)
@@ -919,14 +920,14 @@ singular value problems.")
(define-public gnuplot
(package
(name "gnuplot")
- (version "5.2.7")
+ (version "5.4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnuplot/gnuplot/"
version "/gnuplot-"
version ".tar.gz"))
(sha256
- (base32 "1vglp4la40f5dpj0zdj63zprrkyjgzy068p35bz5dqxjyczm1zlp"))))
+ (base32 "03jrqs5lvxmbbz2c4g17dn2hrxqwd3hfadk9q8wbkbkyas2h8sbb"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)
("cairo" ,cairo)
@@ -938,7 +939,9 @@ singular value problems.")
("texlive" ,texlive-tiny)))
(arguments `(#:configure-flags (list (string-append
"--with-texdir=" %output
- "/texmf-local/tex/latex/gnuplot"))))
+ "/texmf-local/tex/latex/gnuplot"))
+ ;; Plot on a dumb terminal during tests.
+ #:make-flags '("GNUTERM=dumb")))
(home-page "http://www.gnuplot.info")
(synopsis "Command-line driven graphing utility")
(description "Gnuplot is a portable command-line driven graphing
@@ -3502,7 +3505,7 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "20.06.6")
+ (version "20.12.2")
(source
(origin
(method git-fetch)
@@ -3511,22 +3514,20 @@ point numbers.")
(commit (string-append "Version-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "054f7n5kx75ng5j20rd5q27n9xxk03mrd7sbxyym1lsswzimqh4w"))))
+ (base32 "1rxnxk7yanb9ac5pxbii6k7gg3b09pbp9rmwvsvgpbrk17mg79r9"))))
(build-system cmake-build-system)
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("xorg-server" ,xorg-server-for-tests)))
- ;; TODO: Add libomp for multithreading support.
- ;; As of right now, enabling libomp causes the imageCells.wxm test to fail.
+ `(("gettext" ,gettext-minimal)))
(inputs
- `(("wxwidgets" ,wxwidgets)
+ `(("libomp" ,libomp)
+ ("wxwidgets" ,wxwidgets)
("maxima" ,maxima)
;; Runtime support.
("adwaita-icon-theme" ,adwaita-icon-theme)
("gtk+" ,gtk+)
("shared-mime-info" ,shared-mime-info)))
(arguments
- `(#:test-target "test"
+ `(#:tests? #f ; tests fail non-deterministically
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-doc-path
@@ -3537,13 +3538,6 @@ point numbers.")
(substitute* "src/Dirstructure.cpp"
(("/doc/wxmaxima-\\%s") "/doc/wxmaxima"))
#t))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- (setenv "HOME" (getcwd))
- #t))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")