aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d336818299..fe86f810bf 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -55,7 +55,8 @@
%mes-bootstrap-tarball
%bootstrap-tarballs
- %guile-static-stripped))
+ %guile-static-stripped
+ %guile-3.0-static-stripped))
;;; Commentary:
;;;
@@ -797,6 +798,14 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; A stripped static Guile binary, for use during bootstrap.
(make-guile-static-stripped %guile-static))
+(define %guile-3.0-static-stripped
+ ;; A stripped static Guile 3.0 binary, for use in initrds.
+ (make-guile-static-stripped
+ (make-guile-static guile-3.0
+ '("guile-2.2-default-utf8.patch"
+ "guile-3.0-linux-syscalls.patch"
+ "guile-3.0-relocatable.patch"))))
+
(define (tarball-package pkg)
"Return a package containing a tarball of PKG."
(package (inherit pkg)