aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 1897a6d12b..fa3914cde7 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -804,10 +804,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
#t)))
(inputs `(("guile-tarball" ,%guile-bootstrap-tarball)
,@(match (%current-system)
- ("i686-linux" `(("mescc-tools-seed" ,(@ (gnu packages bootstrap) %mescc-tools-seed))
- ("mes-seed" ,(@ (gnu packages bootstrap) %mes-seed))
- ("srfi-43" ,(@ (gnu packages bootstrap) %srfi-43))
- ("tinycc-seed" ,(@ (gnu packages bootstrap) %tinycc-seed))))
+ ((or "i686-linux" "x86_64-linux")
+ `(("bootstrap-mescc-tools" ,%mescc-tools-bootstrap-tarball)
+ ("bootstrap-mes" ,%mes-bootstrap-tarball)
+ ("bootstrap-linux-libre-headers"
+ ,%linux-libre-headers-bootstrap-tarball)))
(_ `(("gcc-tarball" ,%gcc-bootstrap-tarball)
("binutils-tarball" ,%binutils-bootstrap-tarball)
("glibc-tarball" ,(%glibc-bootstrap-tarball)))))