aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 276a89c2a0..0b12f736a9 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -235,7 +235,26 @@ compiler. In LLVM this library is called \"compiler-rt\".")
(substitute* "lib/Driver/ToolChains.cpp"
(("@GLIBC_LIBDIR@")
(string-append libc "/lib")))))
- #t))))))
+ #t)))
+ (add-after 'install 'install-clean-up-/share/clang
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (compl-dir (string-append
+ out "/etc/bash_completion.d")))
+ (with-directory-excursion (string-append out
+ "/share/clang")
+ ;; Delete extensions for proprietary text editors.
+ (delete-file "clang-format-bbedit.applescript")
+ (delete-file "clang-format-sublime.py")
+ ;; Delete Emacs extensions: see their respective Emacs
+ ;; Guix package instead.
+ (delete-file "clang-rename.el")
+ (delete-file "clang-format.el")
+ ;; Install bash completion.
+ (mkdir-p compl-dir)
+ (rename-file "bash-autocomplete.sh"
+ (string-append compl-dir "/clang"))))
+ #t)))))
;; Clang supports the same environment variables as GCC.
(native-search-paths